The Auto-Sleeper Motorhome Owners Forum (ASOF)
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Failure of electronic flush .

4 posters

Go down

Failure of electronic flush . Empty Failure of electronic flush .

Post by Patrick Macdonald Tue Jun 22, 2021 5:05 pm

The toilet in my 2009 Nuevo  (Thetford CW/CWE) has operated well in the two years of my ownership. However on using all the pink flush solution recently, and then refilling it, the press button mechanism fails to produce any flush. The pressed button whirs away in its usual fashion, but no liquid appears. Does this mean a blockage of the system? Any suggestions please.
Patrick Macdonald
Patrick Macdonald
Member
Member

Male

Posts : 30
Joined : 2016-06-21
Member Age : 78
Location : Rugeley
Auto-Sleeper : Nuevo EK
Vehicle Year : 2009

Back to top Go down

Failure of electronic flush . Empty Re: Failure of electronic flush .

Post by Cymro Tue Jun 22, 2021 5:34 pm

A recent thread on the Forum explained that in the circumstances you describe, try filling the WC's cistern (flush-water) tank to the top, and then try flushing. I'd never had that problem in 34 years of owning AS motorhomes - until a fortnight ago. I remembered the advice; it worked!

Cymro
Cymro
Cymro
Donator
Donator

Male

Posts : 2701
Joined : 2011-06-05
Location : Caerdydd - Cardiff
Auto-Sleeper : Nuevo ES
Vehicle Year : 2015

Patrick Macdonald and Mike23 like this post

Back to top Go down

Failure of electronic flush . Empty Re: Failure of electronic flush .

Post by oldfred Tue Jun 22, 2021 6:57 pm

I replaced the electric flush which was often troublesome with the Thetford manual pump. It was easy to fit and can't go wrong.
oldfred
oldfred
Member
Member

Male

Posts : 537
Joined : 2013-07-28
Member Age : 73
Location : North West
Auto-Sleeper : nuevo

Back to top Go down

Failure of electronic flush . Empty Re: Failure of electronic flush .

Post by Askit Tue Jun 22, 2021 7:07 pm

Cymro wrote:A recent thread on the Forum explained that in the circumstances you describe, try filling the WC's cistern (flush-water) tank to the top, and then try flushing.  I'd never had that problem in 34 years of owning AS motorhomes - until a fortnight ago. I remembered the advice; it worked!

Cymro

Me too, exactly the same issue and same solution. Oddly it only happened a couple of times and has reverted to normal again shrugg

_________________
Tony
Askit
Askit
Donator
Donator

Male

Posts : 3204
Joined : 2015-05-16
Member Age : 72
Location : West of Scotland
Auto-Sleeper : Neuvo EK LP
Vehicle Year : 2015

Back to top Go down

Failure of electronic flush . Empty Eureka!!.Flushed with success!

Post by Patrick Macdonald Tue Jun 22, 2021 7:26 pm

Cymro wrote:A recent thread on the Forum explained that in the circumstances you describe, try filling the WC's cistern (flush-water) tank to the top, and then try flushing.  I'd never had that problem in 34 years of owning AS motorhomes - until a fortnight ago. I remembered the advice; it worked!

Cymro
Many sincere thanks, Cymru. I really appreciate your advice! It worked a treat, and the first flush had me brimming over, and in the pink!
Thank you for taking the time to reply and saving me all sorts of concern about how to get it fixed!
Patrick Macdonald
Patrick Macdonald
Member
Member

Male

Posts : 30
Joined : 2016-06-21
Member Age : 78
Location : Rugeley
Auto-Sleeper : Nuevo EK
Vehicle Year : 2009

Cymro likes this post

Back to top Go down

Failure of electronic flush . Empty Re: Failure of electronic flush .

Post by Cymro Tue Jun 22, 2021 7:50 pm

The thanks must go to Merv, who mentioned the cure in this thread:

[You must be registered and logged in to see this link.]

I'm glad it worked in your case, too.

Cymro
Cymro
Cymro
Donator
Donator

Male

Posts : 2701
Joined : 2011-06-05
Location : Caerdydd - Cardiff
Auto-Sleeper : Nuevo ES
Vehicle Year : 2015

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum