The Auto-Sleeper Motorhome Owners Forum (ASOF)
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Nuevo Classic 2010 Battery charging

3 posters

Go down

Nuevo Classic 2010 Battery charging Empty Nuevo Classic 2010 Battery charging

Post by JohnW Tue Feb 06, 2024 5:27 pm

Hi all
On our last trip out the fridge mysteriously defrosted and there was no power going to it and it wouldn’t on mains,12v or gas. Returned home and found that the leisure battery was dead so replaced it and everything worked again.
Whilst the van has been stood overwinter I have hooked it up every couple of weeks but decided to take it for a run but the vehicle battery was flat and so was the leisure battery. In this state nothing on the 12v system worked even when on emu..  Charged both again and everything works however I am suspecting the onboard charger because if you check the voltage with the charger on and off there is no change in the voltage. With the engine running the leisure battery shows 14v with a test meter so looks like that part of the system is working. I have checked the fuses next to the leisure battery and all are okay

Any ideas before I attack. The onboard charger.

NuevoEK 2010

[You must be registered and logged in to see this image.]
JohnW
[You must be registered and logged in to see this link.]
JohnW
JohnW
Member
Member

Male

Posts : 12
Joined : 2023-02-09
Location : SHEFFIELD
Auto-Sleeper : Nuevo Classic
Vehicle Year : 2010

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by Roopert Tue Feb 06, 2024 9:37 pm

Check ~all~ of the fuses. If - for example - you replace the engine battery and you start the van before the leisure battery is replaced, a fuse will blow somewhere, and then charging will be compromised/halted.
Roopert
Roopert
Member
Member

Male

Posts : 3614
Joined : 2019-03-10
Location : South East
Auto-Sleeper : Trooper
Vehicle Year : 2005

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by JohnW Sat Feb 10, 2024 4:53 pm

I have been through every fuse and I am now going to try to change the charger. Has anyone ever done this on a Nuevo?
There are screws around the edge of the wardrobe base ando. The left it is cut around wiring leading up to the circuit breaker unit.
At the back there is vertical boxing which appears to be over the back edge so it doesn’t look as though the base will just lift out because of this. Seems a daft place to put the charger!

Any ideas?
JohnW
JohnW
Member
Member

Male

Posts : 12
Joined : 2023-02-09
Location : SHEFFIELD
Auto-Sleeper : Nuevo Classic
Vehicle Year : 2010

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by Roopert Sat Feb 10, 2024 7:56 pm

If everything on the 12V habitation side works perfectly, and the battery charges while you're driving along as it should, but the 12V leisure battery slowly goes down and down while you're parked up and on EHU, then it certainly sounds as though the 12V charger/power supply may be at fault.

Unfortunately there are several makes of power control system that ~might~ have been fitted to a Nuevo in 2010. If you say what make/model of power control system you have, it may make it easier for people to make helpful suggestions. It would not be unusual for A/S to install a power supply/charger under a wardrobe floor.
Roopert
Roopert
Member
Member

Male

Posts : 3614
Joined : 2019-03-10
Location : South East
Auto-Sleeper : Trooper
Vehicle Year : 2005

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by JohnW Sun Feb 11, 2024 1:50 pm

The charger is a PX300 which I believe is a Sergeant. It all depends on whether I can get Uber the wardrobe floor myself. To change it.
Roopert wrote:If everything on the 12V habitation side works perfectly, and the battery charges while you're driving along as it should, but the 12V leisure battery slowly goes down and down while you're parked up and on EHU, then it certainly sounds as though the 12V charger/power supply may be at fault.

Unfortunately there are several makes of power control system that ~might~ have been fitted to a Nuevo in 2010. If you say what make/model of power control system you have, it may make it easier for people to make helpful suggestions. It would not be unusual for A/S to install a power supply/charger under a wardrobe floor.
JohnW
JohnW
Member
Member

Male

Posts : 12
Joined : 2023-02-09
Location : SHEFFIELD
Auto-Sleeper : Nuevo Classic
Vehicle Year : 2010

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by Peter Brown Sun Feb 11, 2024 2:36 pm

Th PX300 didn't appear until circa 2014 with the EC500. The previous Sargent systems (EC328, EC325, PSU 2007, etc all had integrated chargers. Circa 2010 you cold have an MES system that would have a separate charger but not the Sargent. Do you know the full history of the van?
Peter Brown
Peter Brown
Donator
Donator

Male

Posts : 10438
Joined : 2012-11-10
Member Age : 72
Location : Staffs
Auto-Sleeper : Broadway EB
Vehicle Year : 2016

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by Roopert Sun Feb 11, 2024 5:06 pm

Agreed - the Sargent unit is likely to be a retro-fit, I would think.

Normally I would expect that to have been a good choice - seems to be a reliable unit overall, so I would be a bit surprised if it's failed. But of course not impossible.
Roopert
Roopert
Member
Member

Male

Posts : 3614
Joined : 2019-03-10
Location : South East
Auto-Sleeper : Trooper
Vehicle Year : 2005

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by JohnW Sun Feb 11, 2024 8:35 pm

Thanks all.
The charger is a Volta which I can’t find anywhere online and I thought the PX300 was a likely replacement unless anyone has other suggestions.
Thanks for the replies
John
JohnW
JohnW
Member
Member

Male

Posts : 12
Joined : 2023-02-09
Location : SHEFFIELD
Auto-Sleeper : Nuevo Classic
Vehicle Year : 2010

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by Peter Brown Mon Feb 12, 2024 8:57 am

The PX300 works fine for me.
Peter Brown
Peter Brown
Donator
Donator

Male

Posts : 10438
Joined : 2012-11-10
Member Age : 72
Location : Staffs
Auto-Sleeper : Broadway EB
Vehicle Year : 2016

JohnW likes this post

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by JohnW Mon Feb 12, 2024 12:56 pm

Just one more question.
The Volta unit is receiving power and everything is working on electric hookup but there is no apparent feed to the batteries.
Is it possible that the 12v side of the unit has stopped working?
I’ve been through all the fuses.
JohnW
JohnW
Member
Member

Male

Posts : 12
Joined : 2023-02-09
Location : SHEFFIELD
Auto-Sleeper : Nuevo Classic
Vehicle Year : 2010

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by Peter Brown Mon Feb 12, 2024 2:31 pm

I'm not 100% sure what the symptoms are so:

When all is normal and the leisure battery is fully charged the charger should go onto float mode at about 13.7v. In that mode the charger is acting as a power supply for the habitation 12v electrics but also compensating for any self discharge of the leisure battery.

If the charger is disconnected from the leisure battery for any reason (eg blown fuse or broken wire), the charger when energised will still power the 12v habitation electrics but not charge the battery. If the charger is de-energised (no EHU) none of the 12v habitation circuits will work (including the 12v permanent supply to the fridge that is necessary for the fridge control circuitry to switch between different energy sources).

So, if the 12v circuits work when on hookup with the leisure battery disconnected then their is no fault with the charger - obviously the opposite applies if they don't work.
Peter Brown
Peter Brown
Donator
Donator

Male

Posts : 10438
Joined : 2012-11-10
Member Age : 72
Location : Staffs
Auto-Sleeper : Broadway EB
Vehicle Year : 2016

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by JohnW Mon Feb 12, 2024 5:08 pm

Thanks for that reply Peter.
What happened originally was the fridge went off whilst we were away and on EHU. When we got home discovered that the fuse for the fridge had blown. Discovered that the leisure battery was kaput so installed a new one. All seemed ok again but both vehicle and leisure batteries went flat after about a week with only the vehicle alarm active. Charged both back up and at present everything seems to be working except that is no difference in voltage at the battery with the charger on or off. I will try disconnecting the leisure battery and see if the 12v still works as per you reply.
JohnW
JohnW
Member
Member

Male

Posts : 12
Joined : 2023-02-09
Location : SHEFFIELD
Auto-Sleeper : Nuevo Classic
Vehicle Year : 2010

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by JohnW Tue Feb 13, 2024 5:37 pm

The next instalment
On EHU everything works fine no matter whether the charger is switched on or off.
With the leisure battery disconnected the 12volt doesn’t work but the mains does
Without EHU the 12v works fine off the leisure battery.
JohnW
JohnW
Member
Member

Male

Posts : 12
Joined : 2023-02-09
Location : SHEFFIELD
Auto-Sleeper : Nuevo Classic
Vehicle Year : 2010

Back to top Go down

Nuevo Classic 2010 Battery charging Empty Re: Nuevo Classic 2010 Battery charging

Post by JohnW Thu Feb 29, 2024 5:08 pm

Thank you for your help Peter.
I have fitted PX300 and everything is now working.
JohnW
JohnW
Member
Member

Male

Posts : 12
Joined : 2023-02-09
Location : SHEFFIELD
Auto-Sleeper : Nuevo Classic
Vehicle Year : 2010

Peter Brown likes this post

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum