The Auto-Sleeper Motorhome Owners Forum (ASOF)
Would you like to react to this message? Create an account in a few clicks or log in to continue.

PSU Problem

2 posters

Go down

PSU Problem  Empty PSU Problem

Post by davecrawf Wed Jan 18, 2023 9:00 am

My information panel is displaying the message 'PSU Over temperature  cooling down'
However all electrical items are switched off and the PSU is very cool. Is this maybe a faulty over temp sensor?

_________________
Dave Crawford
davecrawf
davecrawf
Member
Member

Male

Posts : 22
Joined : 2021-04-19
Location : Newcastle-upon-Tyne
Auto-Sleeper : Broadway EK
Vehicle Year : 2010

Back to top Go down

PSU Problem  Empty Re: PSU Problem

Post by PLOUGHLIN Wed Jan 18, 2023 2:45 pm

I had similar with my PSU, Sargent EC325 (same as yours?). Fan working continually. Spoke to Sargent Tech Support, who said "broke and busted", no longer offer repair on EC325. Ended up fitting EC328 and also new Control Pnel as old one won't drive the 328.

Might be worth calling Sargent. [You must be registered and logged in to see this link.]

_________________
Peter L
PLOUGHLIN
PLOUGHLIN
Donator
Donator

Male

Posts : 4391
Joined : 2014-06-24
Member Age : 53
Location : NORTH HERTS
Auto-Sleeper : MB Gloucester
Vehicle Year : 2011

Back to top Go down

PSU Problem  Empty Re: PSU Problem

Post by davecrawf Wed Jan 18, 2023 3:01 pm

Thanks Peter,

I have narrowed the fault down to a dry joint on the main pcb. It is only effecting the charging circuit........I think 🤔 
I am in Spain until March so hopefully I can limp along until I get home. 
I will leave the charging switched off for most of the time. 
Maybe I will end up following in your footsteps. 

Thanks again 

Dave

_________________
Dave Crawford
davecrawf
davecrawf
Member
Member

Male

Posts : 22
Joined : 2021-04-19
Location : Newcastle-upon-Tyne
Auto-Sleeper : Broadway EK
Vehicle Year : 2010

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum