The Auto-Sleeper Motorhome Owners Forum (ASOF)
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Broadway 2009 Water Pump not working

Go down

Broadway 2009 Water Pump not working Empty Broadway 2009 Water Pump not working

Post by smadison Sat Apr 03, 2021 3:37 pm

All,

New to this Motorhome forum and as we bought a used 2009 Broadway Motorhome last year before putting it up for the winter.  Unfortunately as I am getting it ready for a few trip making sure everything is working it appears the water pump is not working, the tank is full as indicated on the panel,  I have changed the fuses the console light illuminates when i turn the water on but I cannot hear the water pump working and when I try to fill the hot water tank up the panel display goes the "Water Tank 100 percent full".  Am I missing something?

Any help would be greatly appreciated from this newbie.
smadison
smadison
New Member
New Member

Male

Posts : 4
Joined : 2020-07-31
Location : Herefordshire
Auto-Sleeper : Broadway ES LP
Vehicle Year : 2009

Back to top Go down

Broadway 2009 Water Pump not working Empty Re: Broadway 2009 Water Pump not working

Post by Paramedic Sat Apr 03, 2021 9:34 pm

Hello and welcome to this most friendly and informative forum. Advice will surely come your way soon.  wave

_________________
In the land of the blind, the man with one eye is king
Paramedic
Paramedic
Member
Member

Male

Posts : 2228
Joined : 2016-01-27
Member Age : 74
Location : Chichester West Sussex
Auto-Sleeper : Broadway FB
Vehicle Year : 2013

Back to top Go down

Broadway 2009 Water Pump not working Empty Re: Broadway 2009 Water Pump not working

Post by inspiredron Sun Apr 04, 2021 12:41 am

Did you drain out the water tank over winter I the first question. If the answer I no then you could have a shedload of problems including split taps. I'll assume that you did drain down.
I am unfamiliar with your water system as my van is 3 years on from yours. The handbook for your van gives all the information you need. If you were not given one then you can download it from the A/S website. 
You are likely to have a Flojet diaphragm pump and an EC325 control panel. Assuming that is correct then check that the EC325 pump switch is on (blue LED beside water pump switch is on). EC325 panel must also be ON. Finally within the EC325 menus ensure that PUMPS is set either to Internal or Both.
With Flojet pumps it is recommended that the water connections to the pump are removed over winter - were they removed and have you reconnected?
I thoroughly recommend that you read the manual which gives you lots of help to track your problem.

_________________
Best wishes - Ron
inspiredron
inspiredron
Member
Member

Male

Posts : 2793
Joined : 2012-06-02
Member Age : 79
Location : Ellesmere, Shropshire
Auto-Sleeper : Lancashire
Vehicle Year : 2012

Back to top Go down

Broadway 2009 Water Pump not working Empty Re: Broadway 2009 Water Pump not working

Post by smadison Mon Apr 05, 2021 12:08 pm

Many thanks for the suggestions, yes the water was drained.  I have since checked to power to the R3426-500 water pump and as it has power but the pump is not working it may best to get someone in to look at it as the pump may be faulty.
smadison
smadison
New Member
New Member

Male

Posts : 4
Joined : 2020-07-31
Location : Herefordshire
Auto-Sleeper : Broadway ES LP
Vehicle Year : 2009

Back to top Go down

Broadway 2009 Water Pump not working Empty Re: Broadway 2009 Water Pump not working

Post by spanner Mon Apr 05, 2021 12:18 pm

Hello and welcome 

Assuming the switches are in the correct position and you still have no water at the taps, can you hear the pump running? If not try giving the pump a tap with a screwdriver handle or similar


 Chris
spanner
spanner
Member
Member

Male

Posts : 150
Joined : 2015-12-04
Member Age : 101
Location : Telford Shropshire
Auto-Sleeper : Broadway EL Duo
Vehicle Year : 2013

Back to top Go down

Broadway 2009 Water Pump not working Empty Re: Broadway 2009 Water Pump not working

Post by smadison Mon Apr 05, 2021 12:20 pm

I can not hear the taps running but will try tapping the pipes, many thanks.
smadison
smadison
New Member
New Member

Male

Posts : 4
Joined : 2020-07-31
Location : Herefordshire
Auto-Sleeper : Broadway ES LP
Vehicle Year : 2009

Back to top Go down

Broadway 2009 Water Pump not working Empty Re: Broadway 2009 Water Pump not working

Post by paul bullock Mon Apr 05, 2021 12:31 pm

Hello again!   told you this forum is good! loads of nice people with good advice, mine still stands ,remedy is to fit a Shurflo as a long term fix , all the best        Regards      Paul wave
paul bullock
paul bullock
Donator
Donator

Male

Posts : 435
Joined : 2013-01-09
Member Age : 69
Location : south west, cornwall
Auto-Sleeper : nuevo ek 2012

Back to top Go down

Broadway 2009 Water Pump not working Empty Re: Broadway 2009 Water Pump not working

Post by spanner Mon Apr 05, 2021 12:48 pm

As you’ve got 12V to the pump you may have a sticky pressure switch, usually a black square box on the end of the pump, 2 wires in and out to the motor, temporarily bypass the switch, if the pump then runs it’s a duff switch, sometimes just needs a few taps to unstick it so try that first.

Chris
spanner
spanner
Member
Member

Male

Posts : 150
Joined : 2015-12-04
Member Age : 101
Location : Telford Shropshire
Auto-Sleeper : Broadway EL Duo
Vehicle Year : 2013

Back to top Go down

Broadway 2009 Water Pump not working Empty Re: Broadway 2009 Water Pump not working

Post by smadison Mon Apr 05, 2021 12:51 pm

up!
smadison
smadison
New Member
New Member

Male

Posts : 4
Joined : 2020-07-31
Location : Herefordshire
Auto-Sleeper : Broadway ES LP
Vehicle Year : 2009

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum