The Auto-Sleeper Motorhome Owners Forum (ASOF)
Would you like to react to this message? Create an account in a few clicks or log in to continue.

problem with on board battery charger.

2 posters

Go down

problem with on board  battery charger. Empty problem with on board battery charger.

Post by willshome Fri Oct 14, 2022 8:19 pm

Hi,
On our last trip away our leisure battery gave up the ghost and was totally discharged. I have now fitted a new leisure battery but the on board charger does not seem to be working. The charging light is on but the leisure battery voltage will not rise above the yellow reading and the AH reading has remained in the red area. Any advice would be appreciated. cheers , Ross
willshome
willshome
Member
Member

Male

Posts : 13
Joined : 2022-08-17
Location : ABERGAVENNY
Auto-Sleeper : mercedes Malvern
Vehicle Year : 2015

Back to top Go down

problem with on board  battery charger. Empty Re: problem with on board battery charger.

Post by Peter Brown Fri Oct 14, 2022 8:56 pm

First check the fuses. There will be on next to the leisure battery under or just behind the front passenger seat and one in the EC500. Check the charger by switching it to the vehicle battery.
Peter Brown
Peter Brown
Donator
Donator

Male

Posts : 9092
Joined : 2012-11-11
Member Age : 70
Location : Staffs
Auto-Sleeper : Broadway EB
Vehicle Year : 2016

Back to top Go down

problem with on board  battery charger. Empty Re: problem with on board battery charger.

Post by willshome Fri Oct 14, 2022 9:02 pm

Many thanks for your reply. I will check the fuse by the battery but where is the location of the fuse for the EC500 battery charger?
willshome
willshome
Member
Member

Male

Posts : 13
Joined : 2022-08-17
Location : ABERGAVENNY
Auto-Sleeper : mercedes Malvern
Vehicle Year : 2015

Back to top Go down

problem with on board  battery charger. Empty Re: problem with on board battery charger.

Post by Peter Brown Fri Oct 14, 2022 9:39 pm

[You must be registered and logged in to see this link.]
Peter Brown
Peter Brown
Donator
Donator

Male

Posts : 9092
Joined : 2012-11-11
Member Age : 70
Location : Staffs
Auto-Sleeper : Broadway EB
Vehicle Year : 2016

Back to top Go down

problem with on board  battery charger. Empty Re: problem with on board battery charger.

Post by willshome Fri Oct 14, 2022 9:45 pm

According to my owners manual the charger fuse is 25amps and is number 15. the above fuse box has only 14 fuses and none are 25 amps. would this fuse be located near the charger under the seat?
willshome
willshome
Member
Member

Male

Posts : 13
Joined : 2022-08-17
Location : ABERGAVENNY
Auto-Sleeper : mercedes Malvern
Vehicle Year : 2015

Back to top Go down

problem with on board  battery charger. Empty Re: problem with on board battery charger.

Post by Peter Brown Fri Oct 14, 2022 9:52 pm

It will be one of the 20A fuses, 13 or 14.

PS, on the sergeant connection diagram it says its fuse 6.

The carpeted cover on the back of the plinth of the front passenger seat is velcroed on and the battery fuse is sometimes behind that cover.
Peter Brown
Peter Brown
Donator
Donator

Male

Posts : 9092
Joined : 2012-11-11
Member Age : 70
Location : Staffs
Auto-Sleeper : Broadway EB
Vehicle Year : 2016

Back to top Go down

problem with on board  battery charger. Empty Re: problem with on board battery charger.

Post by willshome Fri Oct 14, 2022 10:56 pm

Thanks for that. I have replaced the battery fuse and the 20amp fuses and will see if that sorts the issue.
willshome
willshome
Member
Member

Male

Posts : 13
Joined : 2022-08-17
Location : ABERGAVENNY
Auto-Sleeper : mercedes Malvern
Vehicle Year : 2015

Back to top Go down

problem with on board  battery charger. Empty Re: problem with on board battery charger.

Post by willshome Tue Oct 18, 2022 10:00 pm

Update on anyone having similar problems.
There is a 25 amp fuse at the back of the ac 500 unit which can only be accessed by removing the frame around this unit. However this did not resolve the issue. On inspecting the AC 300 charger I pushed in the connections further in and the charger is now working with a visible red light illuminated on the side of it.
This is the second issue I have had with poor connections on these units so if anyone has any similar problems this could be the cause.
willshome
willshome
Member
Member

Male

Posts : 13
Joined : 2022-08-17
Location : ABERGAVENNY
Auto-Sleeper : mercedes Malvern
Vehicle Year : 2015

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum