The Auto-Sleeper Motorhome Owners Forum (ASOF)
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Fresh water pump

Go down

Fresh water pump Empty Fresh water pump

Post by Sparks Mon Apr 19 2021, 06:39

I recently installed a Shuflo pump to replace the Whale in-tank pump, I subsequently had trouble pumping all the fresh water from the tank, so I decided to look inside, the first picture shows the position of the pump which explains why I was unable to empty the tank.
The second picture shows the pump after I removed it, the brown stuff on the top is not sealant, its rust from the metal pipe clip, I would have expected stainless steel as it is immersed in water.
It would appear therefore if mine is the normal method of pump installation, that all the vans with in-tank pumps will also have a rusted clip polluting 
the water.

tr[You must be registered and logged in to see this link.][/url]
Sparks
Sparks
Member
Member

Male

Posts : 26
Joined : 2018-05-29
Location : Bournemouth
Auto-Sleeper : Bourton
Vehicle Year : 2014

Back to top Go down

Fresh water pump Empty Re: Fresh water pump

Post by Caraman Mon Apr 19 2021, 20:22

Yuk.  When the A-S Svc Centre fitted my pump, they made a point of removing the redundant Whale pump.  Even though the tank may be drained and the Shurflo used to draw air through the Whale pump, I suspect traces of water will always be present in it which will encourage biological growth over time.  This will be more so if a Shurflo hasn't been fitted where using the Whale to pump air is very bad for it.  I suppose regular use or water sterilisation would overcome this but not if it causes corrosion as in the photo.
Caraman
Caraman
Member
Member

Male

Posts : 948
Joined : 2019-04-20
Location : SALISBURY
Auto-Sleeper : Nuevo
Vehicle Year : 2019

Back to top Go down

Fresh water pump Empty Re: Fresh water pump

Post by marconi Mon Apr 19 2021, 20:56

I have seen both these problems reported on another thread. You would think A-S would know better.

A-S changed my Whale to a Shurflo under warranty or as a "good will gesture" as they called it, because my Whale Submersible had several problems and the Boiler feed, non return valve was fitted in the wrong position.

They said they would and had removed the Whale, whether they did or not I don't know, overall the standard of workmanship from the Service Center was very poor, it looked like a rush job with some minor damage to woodwork caused and screw covers left off which I found stuck to the EM40 Fuse cover.

Instead of moving the N/R valve which was preventing Boiler drain down, to the correct position, they fitted another in the correct position so unless I had known and pointed it out to them them the Boiler would still not have drained down.
marconi
marconi
Member
Member

Male

Posts : 926
Joined : 2019-03-18
Location : Northamptonshire
Auto-Sleeper : Nuevo EK
Vehicle Year : 2019

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum