The Auto-Sleeper Motorhome Owners Forum (ASOF)
Would you like to react to this message? Create an account in a few clicks or log in to continue.

MES control unit screen not lighting up

Go down

MES control unit screen not lighting up Empty MES control unit screen not lighting up

Post by GWR on Thu Jun 25, 2020 11:03 am

We bought the Nuevo ES about 18 months ago and were told it was a new MES unit. It's been ok until now.
GWR
GWR
Member
Member

Male

Posts : 7
Joined : 2020-06-25
Location : Kingswinford, West Midlands
Auto-Sleeper : Nuevo ES
Vehicle Year : 2008

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by Roopert on Thu Jun 25, 2020 12:11 pm

I'm fairly sure the MES panel has an internal lithium battery - have you tried changing it?
Roopert
Roopert
Member
Member

Male

Posts : 1231
Joined : 2019-03-10
Location : South East
Auto-Sleeper : Trooper
Vehicle Year : 2005

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by GWR on Tue Jun 30, 2020 11:02 am

I`ve just replaced the MES 3v internal lithium battery and the control panel still does not light up and is still `chirping` every minute or so.
I did call the original dealers and was told they would have to connect it to their diagnostic equipment @ £90 per hour, with a minimum of 1 hours work !
Happy days.
GWR
GWR
Member
Member

Male

Posts : 7
Joined : 2020-06-25
Location : Kingswinford, West Midlands
Auto-Sleeper : Nuevo ES
Vehicle Year : 2008

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by Roopert on Tue Jun 30, 2020 12:02 pm

For those who haven't seen the text in "the field that nobody sees" ***, here's the text from the original post:

"The MES control unit screen on our Nuevo ES doesnt light up when I press it. The functions still seem to be working but are very hard to see on the dark screen. The unit also now gives a 'chirp' every 30 secs or so. Does the screen/ unit have its own batt"

I confess I'm not the best person to give any more suggestions, as I've never owned a van with an MES based system. But it sounds like it's sounding an alarm about something - is everything else about the van normal? I.e batteries in good condition, water levels Ok, etc?

One thing I would suggest is that you go through all of the setup screens that the panel provides, just to make sure that all the options are set to sensible values. Hopefully someone who has actually used one of these panels will be able to make some more useful suggestions.

[*** this forum has a weird "feature" that you can enter text in a second subject line that is only visible when viewing the forum index. When you view the post itself, this text is invisible!!!]
Roopert
Roopert
Member
Member

Male

Posts : 1231
Joined : 2019-03-10
Location : South East
Auto-Sleeper : Trooper
Vehicle Year : 2005

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by GWR on Tue Jun 30, 2020 12:52 pm

Roopert, thanks for your interest. I`ve now established it`s the smoke detector, situated next to the MES unit, thats chirping !! ( What a wally ! )
However, to be fair, even though I`ve now replaced the 3v battery and checked it still operates all the systems, the screen is still not lighting up. 
As long as it still worked, the main thing was to stop the chirping, so at least we can now sleep in it ! (It`s possible the small MES screen has downed tools in a strop as we`ve just installed a TV with a much bigger screen ! )
GWR
GWR
Member
Member

Male

Posts : 7
Joined : 2020-06-25
Location : Kingswinford, West Midlands
Auto-Sleeper : Nuevo ES
Vehicle Year : 2008

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by willy eckerslike on Tue Jun 30, 2020 8:53 pm

If you can take the unit out (it’s not difficult) there is a reset switch on the back, a small round black button. Try that first, if that fails try unplugging the connector, wait 30 seconds and reconnect.

_________________
Cheers, Willy
willy eckerslike
willy eckerslike
Donator
Donator

Male

Posts : 371
Joined : 2015-09-09
Member Age : 77
Location : Ayrshire
Auto-Sleeper : Devon
Vehicle Year : 2008

GWR likes this post

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by GWR on Tue Jun 30, 2020 9:31 pm

Thanks I'll try it tomorrow.
GWR
GWR
Member
Member

Male

Posts : 7
Joined : 2020-06-25
Location : Kingswinford, West Midlands
Auto-Sleeper : Nuevo ES
Vehicle Year : 2008

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by GWR on Wed Jul 01, 2020 9:38 am

Just tried small reset button but unfortunately didn`t relight the screen. Also, there is a very small flashing blue light on the circuit board at the back of the unit ?

There are 6 wiring connections, blue `plugs`, to the back of the MES unit but I couldn`t find one main connector ?  ( I did however disconnect the leisure battery which seemed to `kill` the whole MES, it came back on when leisure battery reconnected - would that have been, in effect, option 2 you recommended ? )

Again, although the screen doesn`t light up, all the `touch screen` functions are working, so we can use the Nuevo this weekend as planned.
GWR
GWR
Member
Member

Male

Posts : 7
Joined : 2020-06-25
Location : Kingswinford, West Midlands
Auto-Sleeper : Nuevo ES
Vehicle Year : 2008

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by willy eckerslike on Wed Jul 01, 2020 5:19 pm

Your MES isn’t the same as mine then. I don’t have the blue light and only one connector on the back but yes disconnecting the leisure battery has the same effect as my option 2.
I had to send mine away to MES to get the pin reset, you could try contacting Julie at
[You must be registered and logged in to see this link.] and ask her if they could do anything with it.

_________________
Cheers, Willy
willy eckerslike
willy eckerslike
Donator
Donator

Male

Posts : 371
Joined : 2015-09-09
Member Age : 77
Location : Ayrshire
Auto-Sleeper : Devon
Vehicle Year : 2008

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by Adam & Emily on Wed Jul 01, 2020 10:58 pm

If it is the smallish Display like on my 2007 Nuevo ES, It is usually a bright clear display, but sometimes it is like in a ghost mode where you can hardly see the display. Weirdly if you press firmly on the grey surround casing it comes back to life and stays like it ( sometimes for months). I know that doesn’t explain the issue but it resolves it in the short to medium term
Adam & Emily
Adam & Emily
Member
Member

Male

Posts : 32
Joined : 2018-05-08
Location : Boldmere
Auto-Sleeper : Autosleeper Nuevo ES
Vehicle Year : 2007

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by GWR on Thu Jul 02, 2020 9:13 am

Thanks again for this. I`ve just tried pressing firmly on grey casing etc but no luck, now thinking of trying a hammer ?
Seriously though, thanks to all of you for your responses, although hasn`t got screen lighting up this time it`s very reassuring to know I`m not making a simple mistake.
Fortunately, the unit still does it`s main job OK so we`ll live with a dark screen while I follow Willy`s earlier advice and contact MES.
GWR
GWR
Member
Member

Male

Posts : 7
Joined : 2020-06-25
Location : Kingswinford, West Midlands
Auto-Sleeper : Nuevo ES
Vehicle Year : 2008

Back to top Go down

MES control unit screen not lighting up Empty Re: MES control unit screen not lighting up

Post by GWR on Thu Jul 02, 2020 5:23 pm

Have now exchanged emails with MES.
In summary, no quick fix and need to send unit to them.
Cost of £98 if they can fix/reset screen or £208 if it needs a new screen.
They said these units are good and reliable for at least 5+ years but lengthy periods of non use does seem to cause screens to stop lighting up, like mine.
Again, thanks for all advice etc, we'll use it 'as is' over summer then reconsider.
GWR
GWR
Member
Member

Male

Posts : 7
Joined : 2020-06-25
Location : Kingswinford, West Midlands
Auto-Sleeper : Nuevo ES
Vehicle Year : 2008

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum