Leisure Battery - failed I think

Go down

Leisure Battery - failed I think Empty Leisure Battery - failed I think

Post by cooperman15 on Fri Nov 22, 2019 3:32 pm

We have original leisure battery from first ownership in January 2016 of our 2011 Nuevo.
Checked battery two days ago and it was showing 11.7 on the display, so discharged, I thought ?
Put on charge and the following day showed 12.4 so OK. There was however a slight smell in the van but unsure if it was coming from outside.
Checked today and voltage good but a stronger smell. Took cover off Lucas LeisureĀ  battery and found it was quite hot , the Sargent unit also quite warm.
My conclusion is that the battery has failed but I've not previously experienced a battery getting hot in this manner under charge.
Thoughts and confirmation of my failed battery conclusion would be appreciated.
cooperman15
cooperman15
Member
Member

Male

Posts : 12
Joined : 2017-11-30
Location : Barrow upon Soar
Auto-Sleeper : Nuevo
Vehicle Year : 2011

Back to top Go down

Leisure Battery - failed I think Empty Re: Leisure Battery - failed I think

Post by rogerblack on Fri Nov 22, 2019 5:08 pm

If the battery is getting hot and gassing off then it is potentially dangerous and could cause damage if further charging is attempted. Suggest you disconnect charger immediately if you haven't already done so.

_________________
[You must be registered and logged in to see this image.]
cheers
Roger
rogerblack
rogerblack
Donator
Donator

Male

Posts : 1534
Joined : 2012-09-22
Member Age : 64
Location : Fife / Berkshire
Auto-Sleeper : Pollensa/Boxer2.8HDi
Vehicle Year : 2002

Back to top Go down

Leisure Battery - failed I think Empty Re: Leisure Battery - failed I think

Post by cooperman15 on Fri Nov 22, 2019 5:22 pm

Thanks for the advice, I have disconnected the mains lead and turned off the switch on the Sargent unit. Anything else I need to do ?
cooperman15
cooperman15
Member
Member

Male

Posts : 12
Joined : 2017-11-30
Location : Barrow upon Soar
Auto-Sleeper : Nuevo
Vehicle Year : 2011

Back to top Go down

Leisure Battery - failed I think Empty Re: Leisure Battery - failed I think

Post by rgermain on Fri Nov 22, 2019 6:12 pm

In your position and having been there, I would buy a new battery and cut your losses.

Mine failed after 18 months on a brand new van.

Sorry, but these things happen. moi
------------
Richard
rgermain
rgermain
Member
Member

Male

Posts : 1331
Joined : 2013-11-21
Member Age : 72
Location : Havant
Auto-Sleeper : Warwick duo
Vehicle Year : 2015

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum