Berkshire Leisure Battery not charging

Go down

Berkshire Leisure Battery not charging Empty Berkshire Leisure Battery not charging

Post by NeilH on Mon Jul 02, 2018 5:24 pm

When my 2013 Auto-Sleeper Berkshire is connected to the mains the leisure battery gradually discharges. This happens regardless of whether the power inside the motorhome is switched on or off.
The green charging light on the EC500 Power Control System is flickering all the time but it does not appear to be charging the battery. 
However, when I go on a trip and drive my motorhome the leisure battery charges as I am driving. It charged to 50% last week during a 100 mile journey. 
I usually go to sites with electric hook-up so it has not been a problem so far but has anyone got any ideas why the battery only charges from my vehicle alternator and not the Power Control System? The base vehicle is a Mercedes Sprinter.
Any advice will be gratefully received.
NeilH
NeilH
New Member
New Member

Male

Posts : 4
Joined : 2018-07-02
Location : Droitwich, Worcestershire
Auto-Sleeper : Berkshire
Vehicle Year : 2013

Back to top Go down

Berkshire Leisure Battery not charging Empty Re: Berkshire Leisure Battery not charging

Post by NeilH on Thu Jul 12, 2018 6:12 pm

Problem solved!
I didn’t get any replies from the forum so maybe my problem was unique to me, in any case with the help of the Support guys at Sargent and Mark at Auto-Sleeper my problem is now fixed.
As I mentioned before, my Power Control System is a Sargent EC500 plus I also have a Digital Display Panel which is a Sargent EC480. The fault was that although my leisure batttery would charge from my alternator when driving, it would graduallly discharge when I was parked up on a mains electric hook-up.
The Support engineers at Sargent explained to me how to make sure my control system was, in fact, charging and not faulty.
The instructions were to remove the leisure and vehicle 12V 20A fuses in the EC500 control system then try and switch on the control panel. If the control panel turned on successfully then the charger was working and if it would not turn on then the charger was faulty. In my case it turned on ok so I knew that although my leisure battery was not charging the EC500 was not the cause. I then went about checking fuses, cables and connectors but all seemed to be fine.
I then phoned Auto-Sleeper and explained my problem to Mark. After only a short conversation he told me I needed to reprogram the EC480 control panel and talked me through the process. It seems I have been chasing a fault that does not exist. My control panel was not giving correct information and my leisure battery is actually fully charged. After reprogramming the control panel I now see correct information relating to leisure battery voltage and capacity and everything is fine. I will now go on my next trip with confidence.
I hope this may help someone.
NeilH
NeilH
New Member
New Member

Male

Posts : 4
Joined : 2018-07-02
Location : Droitwich, Worcestershire
Auto-Sleeper : Berkshire
Vehicle Year : 2013

Back to top Go down

Berkshire Leisure Battery not charging Empty Re: Berkshire Leisure Battery not charging

Post by chrisk on Thu Jul 12, 2018 9:16 pm

Glad you sorted it out from one Berkshire owner to another
chrisk
chrisk
Donator
Donator

Male

Posts : 573
Joined : 2017-06-03
Member Age : 69
Location : kent
Auto-Sleeper : Berkshire
Vehicle Year : 2009

Back to top Go down

Berkshire Leisure Battery not charging Empty Re: Berkshire Leisure Battery not charging

Post by NeilH on Thu Jul 12, 2018 11:53 pm

I was beginning to think I was the only one. I have never seen another Berkshire, apart from my own!
NeilH
NeilH
New Member
New Member

Male

Posts : 4
Joined : 2018-07-02
Location : Droitwich, Worcestershire
Auto-Sleeper : Berkshire
Vehicle Year : 2013

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum