Water pump fuse blowing

Go down

Water pump fuse blowing Empty Water pump fuse blowing

Post by Sunbeampizza on Sun Apr 15, 2018 12:53 pm

Just filled the fresh water tank on our Broadway for the first outing this year and find that the 10amp fuse keeps blowing. The van was winterisd ok ie drained with taps left open and the dump valve switched to open. Where is the pump on the van anyway (2012 broadway EK) as the hand book is not very explicit. I suspect it is in the fresh water tank. Any suggestions welcome before I motor 50 miles each way to get the darn thing sorted.
Sunbeampizza
Sunbeampizza
Member
Member

Male

Posts : 55
Joined : 2014-11-30
Member Age : 75
Location : Bucks.
Auto-Sleeper : Broadway EK
Vehicle Year : 2012

View user profile

Back to top Go down

Water pump fuse blowing Empty Re: Water pump fuse blowing

Post by Gromit on Sun Apr 15, 2018 1:19 pm

More info would be useful Sunbeam.

Assuming it is a submersible, has it worked at all since you filled the tank, or did it start blowing fuses as soon as you switched it on? If so, it sounds as if the impeller might have seized, so you could be in a bit of trouble.

If the pump is busted I would strongly suggest you consider getting a Shurflo Trail King instead. There's lots of info on here if you have a search, and by now there have been quite a few members with submersible pump problems - all completely cured by fitting a Shurflo.

The submersibles seem either to work faultlessly, or they are a constant pain in the backside. The big problem is how to get one fixed if it dies in the middle of a French holiday - or after the first hour if Mr Sod is on duty!!!! With a Shurflo it's just a few minutes with a screwdriver.

Have a browse and see what you think from the experience of others.
Gromit
Gromit
Donator
Donator

Male

Posts : 5780
Joined : 2015-03-11
Member Age : 76
Location : Worcestershire
Auto-Sleeper : Nuevo EK LP
Vehicle Year : 2015

View user profile

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum