Beep and red light from EM50 Interface unit

View previous topic View next topic Go down

Beep and red light from EM50 Interface unit

Post by Chinaexplorer on Wed Jun 28, 2017 3:32 pm

On my last trip in my 2010 Broadway I noticed a random chirping noise every few minutes whilst driving - a bit like the noise that smoke detectors make when the battery is low (but it isn't that!). On investigation it appears to come from the EM50 intelligent interface unit behind the driver's seat. There is also a red LED permanently lit on this unit. As far as I can tell everything is working fine: the door step is okay and the fridge appears to be working. Anyone got any idea what might be wrong?  Should the LED be lit all the time or does it suggest that something is wrong?
avatar
Chinaexplorer
Donator
Donator

Male

Posts : 131
Joined : 2011-06-29
Location : Coventry
Auto-Sleeper : Broadway EK

View user profile

Back to top Go down

Re: Beep and red light from EM50 Interface unit

Post by PLOUGHLIN on Wed Jun 28, 2017 4:29 pm

The LED is permanently on in my EM50, but so far it is silent.

_________________
Peter L
avatar
PLOUGHLIN
Donator
Donator

Male

Posts : 1893
Joined : 2014-06-24
Member Age : 47
Location : NORTH HERTS
Auto-Sleeper : MB Gloucester
Vehicle Year : 2011

View user profile

Back to top Go down

Re: Beep and red light from EM50 Interface unit

Post by Chinaexplorer on Wed Aug 23, 2017 11:20 pm

Somewhat embarrassed! The chirping noise was actually from the smoke detector telling me it needed new batteries. Why it only beeped when the vehicle was moving is beyond my understanding. Anyway the problem is solved now as I have replaced the batteries. Ironically the EM50 unit is now giving me a warning buzz every time I go over a bumpy bit of road, but I think that relates to some damage to the rear step. I've not had much luck with the electric rear step and it has got bashed a few times on rough ground, ferries etc. I am now thinking of having it removed to save weight (and save the cost of replacing it). 
oh_blast!
avatar
Chinaexplorer
Donator
Donator

Male

Posts : 131
Joined : 2011-06-29
Location : Coventry
Auto-Sleeper : Broadway EK

View user profile

Back to top Go down

Re: Beep and red light from EM50 Interface unit

Post by Peter Brown on Fri Aug 25, 2017 4:53 pm

PLOUGHLIN wrote:The LED is permanently on in my EM50, but so far it is silent.

The led is there to show the unit is powered and it is on all the time.

_________________
Peter #1
avatar
Peter Brown
Staff Member
Staff Member

Male

Posts : 3409
Joined : 2012-11-10
Member Age : 65
Location : Cheadle, Staffs
Auto-Sleeper : Malvern
Vehicle Year : October 2011

View user profile

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum