sargent panel

View previous topic View next topic Go down

sargent panel

Post by paul long on Thu Dec 22, 2016 2:17 pm

Sargent ec200, not working just keeps beeping. Van been stood for a few weeks and just managed to start, so I ran it for 50 miles to charge the battery up . Still no power to the sargent and still beeping , put it on hook up now and still cant switch the panel on. Can anyone help please. Paul.
avatar
paul long
Member
Member

Male

Posts : 128
Joined : 2016-02-01
Member Age : 61
Location : caunton/ newark
Auto-Sleeper : ascot
Vehicle Year : 2008

View user profile

Back to top Go down

Re: sargent panel

Post by PLOUGHLIN on Thu Dec 22, 2016 2:34 pm

I had similar beeping on my EC350 panel, but with screen message "overheating, switched off to cool". Turned out to be fault in PSU.

Sargent Tech Help are very helpful over the phone. https://sargentltd.co.uk/tech-support.

You could try a reset. Remove bezel, prize off. Remove 2 screws to release. Take off wired plugs. refit plugs, might cure it, if not phone Sargent.

_________________
Peter L
avatar
PLOUGHLIN
Donator
Donator

Male

Posts : 1892
Joined : 2014-06-24
Member Age : 47
Location : NORTH HERTS
Auto-Sleeper : MB Gloucester
Vehicle Year : 2011

View user profile

Back to top Go down

Re: sargent panel

Post by paul long on Thu Dec 22, 2016 2:46 pm

Thanks peter, just done that and its working fine now thankyou.
avatar
paul long
Member
Member

Male

Posts : 128
Joined : 2016-02-01
Member Age : 61
Location : caunton/ newark
Auto-Sleeper : ascot
Vehicle Year : 2008

View user profile

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum