Load sensing valve 1987 Ford Legend

View previous topic View next topic Go down

Load sensing valve 1987 Ford Legend

Post by trevoroq on Thu Apr 09, 2015 8:48 pm

Hi, Had my 1987 Legend fail the mot today, it failed on a loose battery, this was because the tray was rotten with rust, i have a new one on the way, the other thing was the "load sensing valve", i have read that this might have failed because i had no load ( no water , very little fuel and nothing much else ), i am going under the van tomorrow to see if the valve is stuck, if so will try to free it. Does anyone else have experiance with this problem, help would be appreciated. i have found only 1 used one on the net at £70 + fitting, if i cant get mine working i think i will have to get that.scratch head
avatar
trevoroq
Member
Member

Male

Posts : 26
Joined : 2014-06-27
Member Age : 72
Location : Ramsgate Kent
Auto-Sleeper : Legend

View user profile

Back to top Go down

Re: Load sensing valve 1987 Ford Legend

Post by -mojo- on Thu Apr 09, 2015 9:54 pm

I'm not sure it helps much, but you may find that the problem is that the long spring has corroded and broken - I had a Transit that was 12 years younger than yours and it was shocking how badly corroded my spring was. As I say, it may not help that much as I doubt that you can get the spring separately from Ford anyway.

However, if it is only the spring gone, it might be worth speaking to these people, to see if they have something for other models:

http://www.ebay.co.uk/itm/221720578021/
avatar
-mojo-
Member
Member

Male

Posts : 3679
Joined : 2012-08-04
Member Age : 18
Location : Southeast
Auto-Sleeper : Trooper
Vehicle Year : 2006

View user profile

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum